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1. TrueConf Kiosk Overview

1.1. Purpose

TrueConf Kiosk is a software framework for TrueConf Server and TrueConf SDK designed to provide
users with one-way video calls. TrueConf Kiosk can be installed in any hardware was Windows-based
platforms.

We demonstrated how TrueConf Kiosk works in our video: https://youtu.be/igWWPEBHQww

TrueConf Kiosk user interface contains a single “Call” button that calls remote TrueConf. This button is
also used to end the call. Additional customization (button image, company logo, promotional video
playing during standby mode, etc) can be set in the settings menu. You can also set the server or the
user to be called in the same settings screen.

This manual will guide you through main TrueConf Kiosk settings and explain their configuration.

1.2. TrueConf Kiosk features
e 1080p video calls from call agents to customers, dynamically adapting to the communication channel.

e The user interface features two buttons: Call button to call a user in any of the supported call string
formats, and End call button.

e (Calls to SIP/H.323 and RTSP devices.

e Document camera support.

e Automatic call forwarding to the first available operator if the call agent is busy.
e Different options to place your self-view in the video layout.

e Set your company'’s logo to be displayed at the top of the video kiosk screen.

e Customize the Call and End call buttons and select the image that will be displayed on the screen
when authorizing and connecting to TrueConf Server.

e Set promotional video that will be played on the video kiosk screen in standby mode.

e Automatic call and conference recording on the server, if the corresponding option is enabled.
e Control the application using external commands from third-party devices.

e TrueConf Kiosk source code is open, free to use, modify and distribute.

® You can add more than two call agents using TrueConf SDK. The video call escalates into a conference
with several presenters.

e Send documents to print directly to the kiosk using TrueConf Virtual Printer (available via TrueConf
SDK).
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2. How to Open Settings Menu

To open the settings, you could use the following options:

1. Launch the program via the command prompt by entering an additional -config key (learn more
about this feature in the command line control section of our guide).

2. Press Ctrl+Shift+F12 when the program is running.
TrueConf Kiosk settings menu opens on top of the application interface.

No authorization is required to access the settings menu, which is why we strongly recommend
protecting your endpoint from unauthorized access.
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3. How to Connect TrueConf Kiosk to TrueConf Server

TrueConf Kiosk basic setup includes:

e Your TrueConf Server address

e Personal details of the user who will call the server from TrueConf Kiosk

e User (or several users) who TrueConf Kiosk will call upon pressing the call button.

Let's take a look at the settings tabs responsible for the parameters mentioned above.

3.1. «Server and Authorization» Tab

TrueConf Kiosk

- Server and Authorization | view  Call Layout Chat

Server |192.168.1.IDD

User ID |joseph

Password |unnu

Confirm password |uuuu

Show... [~]Keep log file

Hardware

The first tab contains the following fields:

e Server — your TrueConf Server address

Cancel

oK

e User ID, Password, Confirm password — your personal details for authentication on your kiosk. This

user information will be used by the kiosk to make calls.

At the bottom of the tab there's a checkbox called Keep log file. This feature allows you to store
detailed information for every terminal operation in a log file. Click the Show button next to the

checkbox to open the current log file.
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3.2. «Call» Tab

TrueConf Kiosk n
Server and Authorization View
Call to:
User ID |user@server.name |
® One user
The user above should be added to the address book
Comma-separated list

|user1@ser\rer.name, user2@server.name, user3@sewer.name|

() List of users ' Calling the first available user from the list above. All users

must be added to the address book.

/ Calling a random available user from address book
(C) Address book user

Enable manager notifications manager_id@server.name
& Please provide a full ID (e.g. call_id@server.name)
Hardware Cancel oK

In the Call tab you can specify the user whom TrueConf Kiosk will direct the call. It can be a TrueConf
Server user, a SIP or H.323 device, an RTSP camera, or any other device connected with TrueConf Server.

You can check out a detailed description of the string formats for each of those endpoints in TrueConf
Server Administrator Guide on our website. We will only give a couple of examples here:

e <user>[@<server>[:<port>]] - calling <user> from TrueConf Server located at <server>[:
<port>] . The IP number of the server can be used as the address. If @ and the symbols after it are
not specified, the call is forwarded to the server where TrueConf Kiosk is authorized;

e #sip:<user>[@<server>[:<port>]] - calling <user> of the server <server>[:<port>] via SIP
protocol; if the server is not specified, the call will be forwarded to the default server assigned by SIP
Proxy in the SIP-gateway settings of your server;

e #h323:@<ip> - calling H.323 device via IP.

TrueConf Kiosk can make three types of calls that are selected in the Call to area:
e One user — call only one user. User's call string is specified in the User ID field;

e List of users — calls every contact on the Comma-separated list in turn;

e Address book user — call a random contact from the address book of the user who has been
authorized in the kiosk (whose login credentials were entered in the Server and Authorization tab).
You can create an address book in the appropriate section of the TrueConf Server control panel.

At the bottom of the tab there's the Enable manager notifications checkbox. Next to it there's a field
for entering the manager's login and server (the field will be available for entering only if the checkbox is
enabled). When manager notifications are enabled, TrueConf Kiosk will automatically send the
information about its operations and interactions with users back to the manager via text chat.
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4. How to Select Devices?

To select the devices the kiosk will use to make calls, click Hardware at the bottom left corner of the
settings window (this button is always visible in any tab).

A new window will open.

Hardware n
Camera Mone >
Speaker None w
Microphone None A
0K Cancel

There are three fields in this window:

e Camera — a camera that will record the user of the kiosk and transmit the video to the manager on
the line.

e Speaker — an audio output device
e Microphone - audio input device

Select the devices and click OK.

4.1. How to use chat («Chat» Tab)

The manager can send text-only messages to the user via chat. The messages will stay on the screen for
a limited amount of time before they disappear.
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TrueConf Kiosk

Server and Authorization View  Call Layout

Show messages

Chat message display time |5

Hardware

The Chat tab allows you to configure chat display time.

Cancel

OK

Show messages checkbox determines if the text messages sent to the chat are displayed on the kiosk

screen (this feature is enabled by default).

Chat message display time field allows you to specify how long the messages should stay on the screen

before disappearing.
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5. How to Customize Interface («View» Tab)

TrueConf Kiosk provides you with a number of customization features. You are free to customize

TrueConf Kiosk interface and create a personalized look for your terminal.

You can choose your own images in the View tab of the settings window. Click Select... to choose a file
for any field. Click Clear to go back to default settings.

TrueCenf Kiosk

Server and Authorization

Images

Call Layout Chat

Logo | | Select...
Recommended: Width=1272, Height=140
"Call" button image | | Select...
Recommended: Width=1272, Height=98
"Calling" butten image | | Select...
Recommended: Width=1272, Height=98
"End call" button image | | Select...
Recommended: Width=1272, Height=98
"Connecting" button image | | Select...
Recommended: Width=1272, Height=98
Background | | Select...
Recommended: Width=1920, Height=1000
Video
Promo video | |
Recommended: Width=1272, Height=715
[]Force portrait mode
Hardware Cancel

5.1. Size of Images

Clear

Clear

Clear

Clear

Clear

Clear

Clear

oK

Recommended image and video sizes are indicated under each field. These values are calculated based
on the screen resolution of the terminal where TrueConf Kiosk is running. If screen resolution is changed,
restart the application to update the suggested size values.

Compare the recommended settings from the screenshot above (made on a screen with Full HD
resolution 1920 x 1080) with the screenshot below (made on the same screen but in landscape

orientation mode):
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TrueConf Kiosk

Server and Authorization View  Call Layout Chat

Images

Video

Promo video |

Force portrait mode

Logo | | | Select... | | Clear |
Recommended: Width=1080, Height=312
"Call" button image | | | Select... | | Clear |
Recommended: Width=1080, Height=312
"Calling" button image | | | Select... | | Clear |
Recommended: Width=1080, Height=312
"End call" button image | | | Select... | | Clear |
Recommended: Width=1080, Height=312
"Connecting” button image | | | Select... | | Clear |
Recommended: Width=1080, Height=312
Background |D:\DDCS\Pictures\docs\TCA‘I’U\TrueConf| | Select... | | Clear |
Recommended: Width=1080, Height=1840
| | Select... | | Clear
Recommended: Width=1080, Height=1216
Cancel oK

Hardware

Please note that Recommended values have changed.

Enable Force portrait mode to force the program to switch to portrait mode. By enabling this feature,
the video window is stretched vertically and cropped horizontally to fit screens in portrait orientation.

This is how a screen in portrait orientation mode looks like with Force portrait mode option enabled:
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5.2. Customizing user interface

Logo, “Call” button image, “Connecting” button image and other fields in the View tab determine
how kiosk screen elements look like:

e During TrueConf Kiosk loading;

In standby mode;

Call pending;
e During video call.

The following sections explain customization of the interface elements in the View tab.

5.2.1. At Startup

14} TrueConf Kiosk

© | Y TrueConf Hios @ _©

1. Logo bar — your company’s logo
2. This image cannot be customized

3. "Connecting” button image button image bar — an image shown indicating that connection is being
established. This field is also displayed when the connection with the server is absent.

4. Background — screen background

5.2.2. In Standby Mode

o | &?j} TrueConf Hiosk @

PC

&+ — =
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, —
®
Powered by Trusconi
1. Logo bar — your company's logo
2. Promo video - promotional video containing information about your company and the purpose of
the endpoint (it will be displayed only if the kiosk is successfully connected and authorized on
TrueConf Server).
3. “Call” button image — image embedded in the Call button
4. Background — screen background
5.2.3. At Dialup
11 TrueConf Kiosk
 PU—-
Bowered by Trustoni
1. Logo bar — your company’s logo
2. Video from the camera you selected in Hardware settings menu
3. “Calling” button image — the image embedded in the Calling button. The button indicates that the
dial-up is on. You can also press this button to terminate the call.
4. Background — screen background

5.2.4. During Video Call

11! TrueConf Kiosk

[

{}fﬁ} TrueConf Hiosk

L

a\/ﬂ

1B
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Powered by TrusConf

1. Logo bar — your company’s logo

2. Bigger video from the operator's camera. Smaller video from the camera you selected in the
Hardware settings menu. You can change its location or hide it in the Layout tab.

3. “End call” button image - this button ends the call

4. Background - screen background

5.3. Displaying video from a kiosk camera

You can select the location of the kiosk camera image in the Layout tab:

TrueConf Kiosk

Server and Authorization View  Call Layout cChat

. Type when calling:

(O) Hide kiosk camera

(® Kiosk view in the corner

(D) Kiosk views in the middle

Hardware

Cancel

0K

¢ Hide kiosk camera — do not display video from the camera.

e Kiosk view in the corner — display video from the camera in the bottom left corner, over the call

agent's video (this view is used by default).

e Kiosk view in the middle — display video at the bottom center of the screen, over the call agent's
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video.
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6. Managing the application via the command line
You can use the following command line parameters to control TrueConf Kiosk application that is
currently running.

-config — open settings menu for TrueConf Kiosk that is currently running. If the application is closed,
this parameter will launch it and display settings.

-call - make a call according to the settings specified in the Call tab of the settings menu. If
TrueConf Kiosk is closed, this parameter will start the application and initiate a call after the
authorization has been successful. If the application is already busy (calling), this command will be
ignored.

-hangup - end the active call. If the application is not calling at the moment, the command will be
ignored.

-terminate - close TrueConf Kiosk application.
Command line use case:
C:\Users\Kiosk\AppData\Local\Programs\TrueConf\Kiosk\TrueConfKiosk.exe -call

where C:\Users\Kiosk\AppData\Local\Programs\TrueConf\Kiosk\ is the full path to the installed
TrueConf Kiosk application.

poration. All r

:\Users\Kiosk\AppData\Local\Programs\TrueConf\Kiosk\TrueConfKiosk.exe -call_

You can also use shorter commands, such as:
TrueConfKiosk.exe -call
To use shorter commands, you need to run the command line directly from the directory where

the application is installed or add the path to that directory to the Path environment variable in
the Windows settings.
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